User’s Guide to ArcView 3.3 for Land Use Planners in Puttalam District

Dilhari Weragodatenna
# Table of Content

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>1</td>
</tr>
<tr>
<td>1. Getting started</td>
<td>2</td>
</tr>
<tr>
<td>2. Geo-referencing</td>
<td>6</td>
</tr>
<tr>
<td>3. Digitizing (Capturing the Data)</td>
<td>10</td>
</tr>
<tr>
<td>4. Tables and attribute information</td>
<td>13</td>
</tr>
<tr>
<td>5. Calculating field values</td>
<td>14</td>
</tr>
<tr>
<td>6. Modifying the Theme</td>
<td>15</td>
</tr>
<tr>
<td>7. Map Scale</td>
<td>16</td>
</tr>
<tr>
<td>8. Labelling the Map</td>
<td>17</td>
</tr>
<tr>
<td>9. Creating a map Layout</td>
<td>19</td>
</tr>
<tr>
<td>10. Adding Map elements to the layout</td>
<td>21</td>
</tr>
<tr>
<td>11. Exporting a map to PDF, TIFF, JPEG, and other formats</td>
<td>24</td>
</tr>
<tr>
<td>12. Printing the Map</td>
<td>25</td>
</tr>
<tr>
<td>13. Transferring Data from GPS</td>
<td>26</td>
</tr>
<tr>
<td>14. References</td>
<td>27</td>
</tr>
</tbody>
</table>
Introduction

Geographical Information Systems (GIS) is a collection of computer hardware, software, and geographic data for capturing, managing, analyzing, and displaying all forms of data with geographically referenced information. It is the merging of mapping and database technology. GIS is often used as a decision support tool involving integration of spatially referenced data in a problem-solving environment as well. Typically, GIS is used for handling maps of one kind or another. These might be represented as several different layers where each layer holds a particular kind of data. Each feature is linked to a position on the graphical image on a map and a record in an attribute table. GIS can reveal hidden patterns, relationships, and trends that are not readily apparent in spreadsheets or statistical packages, often creating new information from existing data resources. Therefore GIS allows to see pattern, distance, area, relationship, trend, and Location on the ground. And also GIS technology is often used for decision-making, because the data can be easily modified, shared, accessed, updated and linked with photographs, video and audio clips.

Currently, many government agencies as well as non-government agencies in Sri Lanka successfully apply GIS technology as a decision making tool to coordinate resource utilization plans. However, there are often limitations in using of this new technology due to lack of funds for obtaining the relevant software and expertise in the area.

IUCN, International Union for Conservation of Nature and Natural Resources, Sri Lanka implemented the project, Ecologically and socio-economically sound coastal ecosystem rehabilitation and conservation in tsunami-affected countries of the Indian Ocean with financial assistance from Bundesministerium für wirtschaftliche Zusammenarbeit und Entwicklung (BMZ) (German Federal Ministry for Economic Cooperation and Development) in the Puttalam lagoon area in the North Western Province of Sri Lanka. An important component of this project was the capacity building of State Institutions responsible for managing the resources in the Puttalam Lagoon. As a part of this programme, various State Agencies in the Puttalam Lagoon area were provided with GIS Maps incorporating several databases collated and analysed by the Project. The recipients were trained on the GIS techniques. As a continuing capacity building exercise, it was felt necessary that a user’s guide for operating GIS software be provided.

This user’s guide was prepared drawing heavily from Arc View 3.3 help menu and Arc View 9.2 for the sole purpose of providing simplified instructions to the users of GIS maps produced under the BMZ project. Copies of this User’s Guide will be given to selected users free of charge and IUCN does not have any commercial interest in preparing and distribution of this Guide.
1. Getting Started

**Step 1**
- Double click on **ArcView GIS 3.3** in your Desktop (See Fig. 1.1)

![Fig. 1.1](image1)

**Step 2**
- Click **OK** button in the dialogue Box (See Fig. 1.2)

![Fig. 1.2](image2)
Step 3

Open a new View

- To start work highlight view in the project window and click the New button.
- The default name of the new View is View 1.
- To rename the View, choose Properties from the View menu. (See Fig. 1.3)

When the view window is opened rename the new view in Name column.

Fig. 1.3

The basic features of the startup screen are, (See Fig. 1.4)

Fig. 1.4
**Project window**
Shape files are saved in projects (Shape file is a non-topological format for storing the geometric location and attribute information of geographic features. It saves as five files, such as .shp, .shx, .dbf, .sbn, sbx.). The five Project window objects are Views, Tables, Charts, Layouts, and Scripts.

**Menu bar**
User-programmable pull-down menus, uniquely defined for each Project window object.

**Button bar**
User-defined actions (scripts) which are implemented immediately on clicking.

**Tool bar**
User-defined actions (scripts) which apply while the tool is activated (click on, click off)

**Standard View Buttons**

![Standard View Buttons](image)

When move the cursor over each button in standard bar you can see an explanation of its function in the status bar.

The action of some of important button is explained bellow

---

**Save Project** - Saves changes of all works to the project file.

**Add Theme** - Upload data from existing data sources to the view.

**Edit Legend** - Toggle the legend visibility for active themes in the Standard View.

**Open Theme Table** - Display the selected records after graphically select features in a theme. Ensure that the theme in which you selected the features is the only active.

**Query Builder** - It can be built a query by double-clicking on these options with the mouse or by typing your query directly into the query text box.

**Zoom to full extent/Zoom to active theme(s)** - zooms the active window to the extent of all themes in the legend and the active window to the extent of all ACTIVE themes in the legend.

**Zoom to full previous extent** - Zoom the active window back to the previously zoomed area.

**Clear Selection Features** - Unselect the selected features in active themes.
<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Identify</td>
<td>Show database information about a feature.</td>
</tr>
<tr>
<td>Pointer</td>
<td>Select shapes or points by clicking or dragging a box.</td>
</tr>
<tr>
<td>Select Feature</td>
<td>Selects features in the visible, active themes by clicking or dragging a box.</td>
</tr>
<tr>
<td>Pan</td>
<td>Pan can drag by click-and-holding to the inside the view window in any direction.</td>
</tr>
<tr>
<td>Ruler</td>
<td>Measure the distance between two or more points by left clicking on both the starting and ending point.</td>
</tr>
<tr>
<td>Label</td>
<td>Label features with graphic text using database attributes.</td>
</tr>
<tr>
<td>Text</td>
<td>Create text on the display by clicking the location for the text, typing it in the box provided, then positioning it using the “arrow” tool.</td>
</tr>
<tr>
<td>Draw Point</td>
<td>Add graphic shapes to a view by selecting a graphic shape type from the drop down menu of layout options (i.e., points, lines, boxes).</td>
</tr>
</tbody>
</table>
2. Geo-referencing

All the elements in a map layer have a specific geographic location and extent that enables them to be located on or near the earth’s surface. The ability to accurately describe geographic locations is critical in both mapping and GIS. This process is called geo-referencing.

Images are stored as raster data, where each cell in the image has a row and column number. (Raster data is defined by its colours and pixels and is not defined mathematically. Digital pictures are raster data) Shape files and ARC/INFO coverage are stored in real-world coordinates. In order to display images with coverages or shape files, it is necessary to establish an image-to-world transformation that converts the image coordinates to real-world coordinates. This transformation information is typically stored with the image.

**Step 1**

**Select Extensions to Geo-reference**

- In order to add image files (JPEG, BMP, TIFF…) you need to turn on the Extensions from file menu.
- Since Images are JPEG files you have to activate the Image Analysis in the extension menu.
- click OK (See Fig. 2.1)

**Fig. 2.1**

1. Select File
2. Select Extensions
3. Put a tick on Image Analysis
4. Click OK
Step 2

Adding the Raster image data such as aerial photographs, satellite images, etc. as a Theme (Add Data into Arc View)

- Use the Add Theme Button to load the image that you need to geo-reference
- Select Image Analysis Data Source from Set Data Source Types
- Give the path where the image is stored from drivers
- Click OK to add the selected file(s) to your View window. (See Fig. 2.2)

Note: When you select the Image Analysis, Align Tool appear in the Tool Bar

Fig. 2.2

1. Select Add Theme button
2. Select Image Analysis Data Source
3. Select the Drive
4. Click the File Name
5. Highlight the Image
6. Click OK

Step 3

Giving real coordinates in to the Image

- Choose Align Tool from Tool Bar and click on the Land use Type which you can get Real world coordinates (Align Tool should be the first Button from Right in the Tool Bar)-(Land use type can be a Junction, corner of the Lake, Corner of the Building etc)
- Then Right click and choose Enter to Coordinates from the Dialogue Box
- Type the X, Y Coordinates Digits in the To Point Dialogue Box and Click OK
- Give Minimum Four Coordinates to the Image (See Fig. 2.3)
Step 4

Saving the Geo-referenced Image (Raster data)

- Choose **Save Image As** from **Theme** in **Menu Bar**
- Select the **TIFF** from **List files of Type**
- Select the **Directory** to save the Image
- Click the **File Name** where you want to save the Image
- Type Name of the Image in **File Name Bar** and Click **OK** (See Fig. 2.4)
Step 5

Open the Saved Image to continue the work

- Use the **Add theme** Button to load the Save Image.
- Select the **Image Data Source** from Data Source Type.
- Change the **Directory** to your File location.
- Click the **File Name** to highlight the selected Image and **OK**
3. Digitizing (Capturing the Data)

The process of representing an analogue signal or an image by a discrete set of its points is known as digitizing. This data after conversion is in the binary format, which is directly readable by computer. The data to be converted can be a text, an image, audio or a video. When you digitize a map, you use a digitizing tablet connected to your computer to trace over features you are interested in. The X, Y coordinates of these features are automatically record and store in the computer as spatial data.

Step 1

Creating a New Theme

You are now ready to digitize features in ArcView.

- Choose **New Theme** from the View Menu.
- Choose **Polygon** from the list of choices in Feature type (Point, Line, and Polygon)
  All the editing and drawing tools that you can use with the mouse are available using the digitizer. Choosing the correct tool is very important in order to be productive and to digitize features accurately.
- Choose the default or provide a name and location for the new theme. (See Fig. 3.1 and 3.2)

**Fig. 3.1**

1. Click View and New Theme
2. Select Type
3. Click OK
Step 2

Capturing data

If you want to edit an existing theme, make it active and choose Start Editing from the Theme menu. If you just want to add graphics to your view without creating a theme, go ahead and digitize.

- Click a theme legend box to make it “Active” (theme is surrounded by a box and appears raised). A theme can only be edited when it is “Active”.
- Go to Theme and select Start Editing.
- Choose the Draw Polygon tool from the “Drawing Tools” drop-down menu.
- Click on the "drawing tool" pull-down menu button and select the drawing tool matching the shape of the "active" theme (See Fig. 3.1).

Use this tool if the “active” theme is a point
Use this tool if the “active” theme is a line
Use this tool if the “active” theme is a multi-point line
Use this tool to draw a rectangle
Use this tool to draw a circle
Step 3

- Draw the polygon by clicking for each vertice *(the cursor will be a crosshair)*. Double click on the last vertice.
- If you want to continue the drawing, right clicks and selects **Pan** to move.
4. Tables and attribute information

Tabular information is the basis of geographic features, allowing you to visualize, query, and analyse your data. In the simplest terms, tables are made up of rows and columns. In GIS, rows are known as records and columns are fields. Each field can store a specific type of data such as a number, date, or text.

Step 1

Insert Data into a table

- Click the **Open Theme Table** button in the View button bar.
- Add fields to the table from the **Table Menu** bar and select the **Add Field** choice from the Edit menu. The Field Definition dialog box will appear allowing you to define the field in the table.
- Add records to the table from the **Table menu bar**, select the **Add Record** choice from the Edit menu. This will add a single record to the table. Repeat this action as many times as needed.
- Add data to the table from the Table tool bar, select the **Edit tool**. This allows you to edit the empty cells in the table.
- To edit the values in a table, From the **Table menu**, Choose **Start Editing**.
- Select the **Edit tool** and place the cursor in the field of the record you want to edit. Type the new value into the field. When using the Edit tool in the table, the following keyboard accelerators are supported for the editable cell.
- To finish editing and commit your changes, choose **Stop Editing** from the Table menu. (see Fig. 4.1)
5. Calculating field values

Entering values with the keyboard is not the only way you can edit values in a table. In some cases, you might want to perform a mathematical calculation to set a field value for a single record or even all records. The ArcView field calculator lets you perform simple as well as advanced calculations on all or selected records. In addition, you can calculate area, length, perimeter, and other geometric properties on fields in attribute tables.

Step 1

To calculate a value for a field

- Choose **Start Editing** from the Table menu.
- Click on the name of the field you wish to calculate. Note that the names of fields you can calculate appear in a normal font, any that you can't are shown in italics.
- Click the **Calculate** button.
- In the Field Calculator dialog that appears, type the expression for the calculation in the input area of the dialog box. You can use the field and request list items to help you form the expression by double-clicking on field names and requests or you can type the expression yourself.
- Press **OK** to perform the calculation. ArcView displays the results in the table. (See Fig. 5.1)

Type the following into the expression box
For length:
[Shape].ReturnLength/1000000
For area:
[Shape].ReturnArea/1000000
For perimeter:
[Shape].ReturnLength/1000000

**Note - The calculation applies to the selected set of records. If no records are selected, the calculation applies to all records.**

Fig. 5.1
6. Modifying the Theme

A Theme is a collection of features drawn on a view. A Theme has an associated legend that defines the symbolization of the features.

Step 1

Changing Theme Properties

- Open the **Legend Editor** box by double-clicking the theme legend box; or by clicking **Theme** on the menu bar, then clicking **Edit Legend**.
- Double-click the **Symbol box** in the Legend Editor to open the “Theme Properties Editor”. Edit the theme’s properties by using the buttons on the palette.
- From **Fill Palette** you can change the Pattern of the Legend.
- From **Color Palette** you can change the color of the Legend.
- Finish the Editing **Click Apply** (see Fig. 6.1).

**Fig. 6.1**

1. Double Click the Theme
2. Double Click the Symbol
3. Select the Fill Pattern
4. Click Apply
7. Map Scale

Map scale is the relationship between the dimensions of a map and the dimensions of the Earth. It is usually expressed as a ratio, like 1:63,360. The scale ratio 1:63,360 means that one unit of distance on the map represents 63,360 of the same units of distance on the Earth. So on a 1:63,360 scale map, one inch on the map equals one mile on the ground because one statute mile has 63,360 inches. Because the scale ratio is a constant, it is true for whatever units in which the fraction is expressed. So on a map with a scale of 1:24,000, one centimeter equals 24,000 centimeters on the ground, just as one inch represents 24,000 inches.

Step 1

Setting Map Scale

Map units are the units of the view’s display surface. If the view has not been projected, Map units are the units in which the coordinates of the spatial data contained in your view are stored. If the view has been projected, Map units are the units into which this data is being projected in the view. ArcView uses the map units setting to determine the correct scale of your view. If Map Units are not set correctly, the scale ArcView displays for your view may be incorrect, and ArcView won’t know how large to draw your view if you specify a scale for your view.

- Click View on the menu bar to pull down the “View” menu. Then click Properties to open the “View Properties” window.
- Select Meters in Map Units and Kilometers from Distance Unit.
- Then click OK (See Fig. 7.1).

Fig. 7.1

1. Click View and select Properties
2. Set Map Units
3. Scale will appear here
8. Labelling the Map

ArcView has three ways for you to label the features in the theme.

1. Interactively position and enter your own text

   - Choose the text tool from the **Standard tool bar**.
   - Position and click the cursor on your view where you want your text to begin.
   - Type your text into the Text Properties dialog and click **OK**. (See Fig. 8.1)

   ![Fig. 8.1](image)

2. Interactively position a label based on an attribute value

   - Make the theme that contains the features you want to label active by clicking on it in the table of Contents.
   - From the **Theme** menu choose **Properties**.
   - Choose the **Text Labels icon** in the **Theme Properties** dialog.
   - Choose the **field** that contains the values you want to use as labels and then click **OK**.
   - Select the **Label** tool.
   - Click on the feature you want to label. The label appears where you clicked.
   - Choose the **Stop Edit** from Theme Menu and **Save** the Edit of the Theme. (See Fig. 8.2)
3. Automatically label some or all features
You can label all features or just selected features for an active theme.

- Click on **Auto-label** from the Theme menu.
- Select Auto-label either all the features of the active theme or a selected set of features. (See Fig. 8.3)
9. Creating a map Layout

Producing the output of your work is one of the end product in GIS work. A layout is a document which collection of map elements laid out and organized on a page. Common map elements include one or more data frames each containing an ordered set of map layers, a scale bar, north arrow, map title, descriptive text, and a legend. Layout view is where you add map surrounds, frames, graticules, and other finishing touches to a map. It can then draw those objects to the screen, send them to a printer, and send them to one of several standard graphics file formats.

Step 1

- Choose Layout from View Menu.
- Select Page Pattern (e.g. Landscape, Portrait.)
- Click OK.
- Click on New Layout. (See Fig. 9.1)

Fig. 9.1

Step 2

Setting the layout page size and orientation

When you want to create a map using a layout you will need to define some characteristics of the layout page. These include: page size, page units, orientation, and margins. (See Fig. 10.2)

Page size
There are a number of large and small format sizes provided by default in ArcView. If you need a size other than these, you can use a custom page size and define its width and height. The default page size is derived from your printer.
Page units
Select page units from a list of choices. The default page units are inches.

Orientation
Choose between landscape and portrait orientation for the layout page. The default orientation is derived from your printer. If you change the orientation, any new layouts will use the new orientation as the default.

Margins
Define margins for the page or use your printer's default margins.

Output resolution
Defines the resolution the layout is printed and exported.

Fig. 9.2
10. Adding Map elements to the layout

Step 1

Scale

Scale bars are contained within frames in the layout. When you create a scale bar frame, it is associated with a view frame. If the view frame is live linked, and the scale of the view is changed by zooming in or out, the scale bar will update accordingly.

- Select **Scale Bar Frame** from Tool Bar (Second Button form Right with Ruler Sign).
- Drag on the View.
- Select the **View Frame**.
- Select **Kilometers** from **Units**.
- Click **OK**. (See Fig. 10.1)

Fig. 10.1

**Step 2**

Title

- Select the **Text** tool.
- Click where you want your text to begin.
- Type your text in the **Text Properties dialog** and click **OK** (See Fig. 10.2).
Step 3

North Arrow

North arrows are contained within frames in the layout. When you create a north arrow frame you select a style of north arrow to place on the layout. You can also choose an angle (in degrees) that the north arrow should be rotated.

- Select **North Arrow** from **Tool Bar** (The second Button from Right with Arrow sign)
- Drag on the View
- Select **North Arrow Style**
- Click **OK** (See Fig. 10.3)
Step 4

Legend

Legends are contained within frames in the layout. Legend frames contain a representation of a view’s Table of Contents. When you create a legend frame, it is associated with a view frame. Whichever themes are drawn in the view will be shown in the legend. If the view frame is live linked, and a theme is turned on or off, the legend updates accordingly by adding or removing the theme symbol and text. (See Fig. 10.4)

Fig. 10.4
11. Exporting a map to PDF, TIFF, JPEG, and other formats

You can export a layout to a file in any of a number of supported output formats. ArcView exports to the following formats: UNIX windows, Placeable Windows, Metafile, Windows Metafile, Windows Bitmap, Encapsulated PostScript – New, Encapsulated PostScript – Old, Adobe Illustrator, CGM Binary, CGM Character, CGM Clear Text, JPEG

Step 1

Export the Layout as JPEG

- Click **File**
- Select **Export**
- Select **JPEG** from File type
- Select **Drive**
- Select **File Name**
- Give a name to the Map
- Click **OK** (See Fig. 11.1)

![Image of ArcView interface steps]

Fig. 11.1
12. Printing the Map

ArcView supports for getting hardcopy output. The printing tools within ArcView allow you to print Layouts directly from the view and export to a file in the computer.

**Step 1**

- Choose **Printer** From the **File** menu,
- Set Output Format to Printer Specific
- Click **OK** (See Fig. 12.1)

![Fig. 12.1](image-url)
13. Transferring Data from GPS

GPS (Global Positioning System) is an electronic satellite based system which provides satellite-based navigation system. The GPS transmits signal information from satellite at all times, in any weather and to any place on earth. GPS receivers use this information to calculate the user’s exact location which is displayed on the units map.

There is no option (Tool bar) to take GPS information to the ArcView 3.3 directly. Therefore data can be transferred as shapefiles via Oziexplora or Vantagepoint softwares only.

**Step 1**

**Transferring and exporting data from GPS to Vantagepoint**

- **Connect** GPS to the PC
- Click on **import** Button
- Data will **save** in the Vantagepoint
- Click on **export** button and select the type that you want (See Fig. 13.1)

![Image of Vantagepoint software interface showing Import and Export buttons]

Fig. 13.1
Step 2

Transferring and exporting data from GPS to Oziexplorer

- **Connect** GPS to the PC
- Click on **Magellan** and select **Get Waypoint from GPS** Button
- Click on **File** and select **Export to Esri Shapefile** and select waypoint to points
- Give a path for save the file

**Fig. 13.2**

14. References

ArcGIS Desktop Help, ESRI
ArcView 3.3 Desktop Help, ESRI
IUCN, International Union for Conservation of Nature

IUCN was founded in 1948 and brings together 80 states, 114 government agencies, more than 800 NGO’s and some 10,000 scientists and experts from 181 countries in a unique worldwide partnership.

The Mission of the Union is to influence, encourage and assist societies throughout the world to conserve the integrity and diversity of nature and to ensure that any use of natural resources is equitable and ecologically sustainable.

The IUCN in Sri Lanka was established in 1986 and is guided by IUCN’s mission and the environmental concerns embodied in successive National Environmental Action Plans of the Government of Sri Lanka.